HP 9000 – it’s alive!

January 17, 2008

Wow – this one was smooth sailing after finally getting the right CR-ROM drive hooked up.  The HP-UX install process took about as long on this machine as did the DEC 9000 OpenVMS install.  A notable difference between the two is that there were no errors incurred by the HP-UX install.  Even though I tried to cause myself some grief by incorrectly configuring the network settings, HP-UX recognized my potential for mistakes and put something on the screen to tell me how to redo the network settings later on without having to scour the web for instructions.  Like a long lost friend who knows my potential for losing information, it even left me an email on the machine to reiterate the process for making configuration changes – that’s a big gold star for user-friendliness.

Bottom line is that I now have this machine up and running with the OS it was intended to run, and I have one more item checked off of my “building the eclectic office” goals list.  Only thing left to do right now is to pretty it up just a bit with some of my open source favorites like bash, openssh, and gcc.  Then, on to the next machine…


HP 9000 – finally some progress

January 17, 2008

It’s been a while since I messed with the 9000.  In fact, I actually stole its 1 GB drive a while back for use in my TT.  Yesterday at the office, I stumbled upon a 4 GB drive in the junkpile that (assuming it was still functional) would be perfect for this box.  I actually rebuilt the machine once after I brought it home, but I had so much trouble trying to figure out a way to install HP-UX on it that I gave up and did a network Debian install.  That worked well and ran fine, but it was very much against the spirit of my goal to regain another OS that I used to work with.  So, tonight I was determined to finally get HP-UX onto the box.  That meant getting around the fact that the machine has no CD-ROM drive, you cannot install HP-UX from a floppy drive, and you cannot netboot an HP-UX install from anything but another HP-UX machine.  This would be fun…

Software-wise, I was already in good shape thanks to an HP-UX 10.20 original CD set that I acquired from someone who replied to my call for help in comp.sys.hp.hpux (who says Usenet is dead?) with a very reasonable price of $20 shipped.  They’ve been tucked away just waiting for another shot, and tonight was the night the would get it.  Tonight was the night I managed to get the right CD-ROM drive temporarily added to the internal SCSI chain, typed “boot scsi.1”, and nearly did the Dance of Joy when I started seeing boot messages from the install CD!  In case you’re wondering, I only DIDN’T do the dance because there is currently not that much open floor space in my computer room.

Once the install kicked off, I answered just a few questions and sent it on its way.  As I write this post, I see the installation process I began before starting on the post is currently on package 38 of 243.  It’s going to be another waiting game.


DEC 3000 – later that evening

January 16, 2008

After listening to the OpenVMS install churn away for somewhere between 2 and 3 hours, it finally stopped.  As I eagerly approached the machine in hopes of seeing something like “install complete – press any key to boot from dka0:”, the image of utter failure formed in front of my eyes in the shape of a single add-on package that failed to install.  It happened to be the TCP/IP package, so I would have thought it could have finished everything else so that I could do TCP/IP later on myself (since it’s not a required package).  Sadly, that was not the case.  That single failure was enough for the install to give up completely and leave me with a completely useless system.  There’s one strike against OpenVMS.

Not really wanting to sleep anway, I decided try the install one more time and hope for the best.  This time, I did NOT select the TCP/IP package to be installed, and I sent it off churning again for a couple more hours.  What would it choke on this time?  Believe it or not, nothing!  Install finished, I booted into my shiny new OpenVMS 8.3 OS.  I installed the hobbyist licenses, and I eventually figured out how to install TCP/IP manually, which installed just fine on the first try.  Go figure.

A little history: One of my current goals in the retrocomputing scene to to reacquire as many of various types of hardware and/or OS platforms as I’ve used regularly over the years.  VMS happens to be one of them that dates back to my college years.  We had a VAXCluster running VMS that was the university’s primary general purpose system.  People read their email, chatted, play games, did homework, etc. on all the VT nodes set up across campus.  Since acquisition of a VAX mainframe really isn’t practical, the DEC 3000 will have to do. 🙂

Besides getting the 3000 generally set up and networked, I have been playing with a number of random utilities, building a few from scratch, using it to browse the web and hit IRC channels on occasion, etc.  Also, since the existing hard drive is only 1 GB, I also just added a second 2 GB drive to use for extraneous utility programs and user data.  Things seem to be running smoothly.

More later, after the other machines catch up!


DEC 3000 – the test of time

January 16, 2008

It’s not every day I can bring home a 14-year-old computer, pair it with an operating system that is currently being developed, licensed, and supported by a major vendor and expect it to work. Could I bring home a copy of Windows Vista (not that I’d want to) and put it on a 486-based PC? No. Could I Bring home a copy of Mac OSX Leopard and put it on my IIci? Not gonna happen. However, that is exactly what I’m doing with the 3000.  Will a modern OS reduce the machine’s retroness?

The OpenVMS 6.1 installation that came on the machine was configured very specific to its old environment, and plus I eventually lost the login information for it. 🙂 When trying to determine the most appropriate OS for the box, I hit up the comp.sys.dec newsgroup and received a number of friendly replies. Some of them suggested I should try to upgrade at least the RAM and maybe the hard drive, but, without exception, everyone recommended that I get the lastest version of OpenVMS – 8.3 – and run with it. It’s a rare thing these days to see some vendors who actually continue to make improvements to software performance without requiring new investment in hardware to run it. Still, I kept my options open based on what I could get ahold of for the least, hopefully no, cost.

Fortunately, one reader of my newsgroup post replied and offered me a copy of his OpenVMS 8.3 install media. That means I won’t have to pay HP to send it to me, and it’s not even illegal to make copies under their licensing model. Sweet! Also, I found out that you can actually obtain FREE licenses to use OpenVMS, along with its plethora of companion applications, in a non-commercial environment simply by signing up at your local DECUS affiliate (ENCOMPASS here in the USA) and requesting hobbyist licenses. So, just download the 8.3 install image and I’m all set, right? Well, not quite.

Native VMS CD images are interesting beasts in themselves. They typically use the ODS-2 or ODS-5 format, each of which is specific to the RMS filesystem used in VMS. On the flip side, most PC CD burning software will not properly burn an image that does not somewhere contain an ISO-9660 filesystem. After trying various approaches, the only exception I found to this rule to this rule is a package called GEAR PRO. Fortunately, GEAR has 30-day trials of all their products, because I ended up needing the Mastering edition in order to open a “foreign” (raw) image and burn it to CD. This pretty much means I have a few weeks left to burn any other VMS images I may need to obtain, because the $399 price tag is a little steep for me. 🙂

Once I finally found the correct piece of software to burn my CD, I popped the CD in the 3000, gave it the boot command, and off into the install program it went. Sweet! A couple minutes of whirring later, the install halted and told me that the firmware on the 3000 was way too old for it to even consider loading the operating system onto it. Crap! After some searching, though, I located the latest firmware on HP’s site. I would just grab the firmware CD and do another foreign CD image. Sweet! Then I noticed that the firmware for older machines is not available in the standard update CD image, so I’d have to download the package as a single file. That would’t do me much good, though, because I don’t have a floppy drive in the 3000. Crap! What does this mean? It means I had to dive back into setting up my linux machine to provide BOOTP networking setup and TFTP file access for the 3000 to grab and load the new firmware.

To keep a long story from getting longer, suffice it to say I struggled with getting both ends of the BOOTP setup working properly. The biggest issue ended up being the fact that I didn’t have the correct boot command to tell the 3000 to actually go out and look for its info. Once I found that, the firmware update ran smoothly. After it was done, I once again booted the box, the 8.3 install kicked off, and voila! This time, it moved on, collected information, and began installing the operating system. This was the last interaction I would have with the process for the next couple hours…


Spectre GCR – I ain’t afraid of no ghost

January 16, 2008

This is actually the piece of hardware I had started playing with when it was suggested by a peer that I might considering documenting some sort of related project for the RetroChallenge.  I replied with something like “yeah, maybe” and went on with my experimentation…

I have heard lots of good things about this device, and it seems very cool indeed.  You plug it into the expansion port on the side of any ST/TT computer, run the provided software to configure and manage your Mac emulation, and start it up (well, more or less).  Compared to the Mac hardware available when the GCR was developed, this would actually give you a much faster Mac system than you could go out and buy.  Its use even promoted the listing of the Atari ST in various literature of the period as a “Mac clone”.

So, the first step was to get the thing plugged into my TT and verify that it at least starts up.  I plugged the device into the expansion port, attached a floppy drive cable between the device and floppy port on the TT, and copied the latest revision of the software onto my hard drive.  Following instructions in the manual, I was able to boot the device up to the point of the familiar grey screen with a picture of a disk and question mark to indicate that it is now up to me to figure out how to actually get some software installed.  That is turning out to be no small task…

According to the documentation, the Spectre can read both native Mac (GCR) and Spectre formatted floppy disks and, of course, boot from them.  Also, user reports show that the top operating system that was really supported is Mac OS 6.0.8, which is just fine with me.  So, I grabbed the DiskCopy images for the Mac OS 6.0.8 install floppies, created physical floppies on one of my own Macs, and gave them a whirl.  The install floppy, while it could verifiably boot my actual Mac, was unable to boot the emulated Mac.  I tried another OS revision, different floppy disk density, and the addition of an external floppy drive in my effort to get the boot disk recognized as a system disk, all with no luck.

All may not be lost, though, because the Spectre has a very important feature – its hard drive emulation is actually not emulation.  Spectre uses the same phyical SCSI disk partitions as a real Mac, and that’s what I intended to eventually install onto using the install floppy I made.  Since that does not seem likely, the option seems to be to actually install the OS on a hard drive in a real Mac and then transfer the drive to the TT.  Assuming this is a viable approach, which it appears to be, there may still be some caveats to overcome.  For one thing, Spectre only supports hard drives on SCSI controllers that are attached to the Atari’s ACSI port.  That means I need to get my ICD host adapter back out and try to find a drive lying around that works with it, which is hopefully easier to do on a TT that it is with earlier ST machines.  Also, of course, this drive will have to work in the actual Mac.

As of now, I have located an Apple OEM 500 MB SCSI drive that I will try to use for this transplant operation.  We’ll see how it goes…


Revival of the fittest…

January 16, 2008

Over the past couple weeks, I’ve taken on the task of gathering up a number of classic machines that have been sitting around my house in non-running condition and bringing them back to life.  All of them are in pretty good shape hardware-wise (some needing new hard drives) but without any installed software to run them, which always makes me appreciate my 8-bit machines that need nothing more than OS ROMs to get them booted.  So, this will be a journal, I HOPE, of the journey back to functionality for 3 1/2 machines that are currently collecting dust:

* DEC 3000-M600 (circa 1994) – This machine sports a 175 MHz Alpha AXP 21064 processor with 64 MB RAM and a 1 GB SCSI hard drive.  I picked it up this summer at the Vintage Computer Festival Midwest for the grand sum of $30 (including 17″ Digital monitor, keyboard, and mouse).  It was running a Purdue University installation of OpenVMS 6.1 and, of course, did not include any re-installation media or current license for the software.

* Amiga 3000 (circa 1990) – This machine has been upgraded to a 25 MHz 68040 processor and 80 MB FastRAM.  It also includes ethernet, CV-64 3D graphics, and Sunrize Studio16 cards.  I picked it up this spring, along with a keyboard and mouse, with the transportation help of fellow classic computing folks.  I don’t remember what OS was installed when I received the machine, and it also came without re-installation media.

* Spectre GCR (circa 1989) – This is where the 1/2 comes in.  The Spectre is an add-on device for Atari ST/TT computers that provides Macintosh hardware emulation using installed OS ROMs from a Mac Plus or similar 128K machine.  I acquired the Spectre just last month on eBay, complete with installed ROMs, docs, and software.  I will be working with it attached to my Atari TT030.

* HP 9000 712/60 (circa 1994) – This is a late addition to the list for this project.  It needs to be rebuilt as well, so I might as well take care of them all!  The 9000 boasts a 60 MHz PA7100LC RISC processor and 32 MB RAM.  I brought this home from the office over a year ago after it sat in storage at the office for about 6 years.  Prior to that, I had actually used it for work purposes, and I believe it had HP-UX 10 on it.  You guessed it – no re-installation media could be found.

So, those are the machines I plan to bring back to life, and my end goal for this project is to get them all networked and particating in some common task.  I haven’t yet figured out what that task will be.  I also hope to post pictures any anything else interesting as I go.

3 1/2 neglected classic machines: This is their story…